Page 1 of 1

Old C++ in New Primalscript release

Posted: Mon Dec 03, 2018 7:17 pm
by TCCDesktopOps
Product, version and build: Primalscript 7.4.119.112918
32 or 64 bit version of product: x64
Operating system: Win 7 and 10.1803
32 or 64 bit OS:x64
---------------------------------------------------------------------------------------------------------
This release of Primalscript has old versions of C++ included in the package which cause deployment from SCCM to fail if a newer C++ is already installed.

The x86 version packaged with Primalscript is 14.13.26020.0
The version I have is 14.14.26429
The latest version at time of writing was 14.16.27012.6 - https://support.microsoft.com/en-au/help/2977003/the-latest-supported-visual-c-downloads

Message in the logs on failure is - "Error 0x80070666: Cannot install a product when a newer version is installed"

are you able to either
- configure the package to continue if a later c++ version is detected (best option) OR
- add the latest versions of C++ to the Primalscript deployment.

my command line is - PSR19Setup_7.4.119_112918_x64.exe /exebasicui /exenoupdates /exelog c:\soe\Install_Primalscript2019-7.4.119_112918.log /qb

As I see it currently, my alternative is to change my single line install command to a scripted install to detect and uninstall any possible later version of C++ 2019, install primalscript, then install the latest version of C++.

Re: Old C++ in New Primalscript release

Posted: Tue Dec 04, 2018 7:52 am
by Alexander Riedel
I'll check into that.

Re: Old C++ in New Primalscript release

Posted: Tue Dec 04, 2018 9:59 am
by Alexander Riedel
We are in the process of updating to the latest runtime. However, as you can imagine that requires additional testing, so I have no time line at this moment.
The installer currently checks for a later version of the runtime that it includes, so that is a bug that will also be remedied in the next service build.