Background jobs not processing

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
whiggs2
Posts: 38
Joined: Sat Sep 23, 2017 11:59 pm

Background jobs not processing

Post by whiggs2 » Wed May 09, 2018 6:27 am

To help you better we need some information from you.

*** Please fill in the fields below. If you leave fields empty or specify 'latest' rather than the actual version your answer will be delayed as we will be forced to ask you for this information. ***

Product, version and build:
SAPIEN Powershell Studio 2018
Version 5.5.152
32 or 64 bit version of product:
64-bit
Operating system:
Microsoft Windows 10 Enterprise
10.0.16299 N/A Build 16299
32 or 64 bit OS: 64 bit

In order to create powershell GUI scripts which are responsive, I have been using the framework designated in the below link in order to run the processes associated with control events as background jobs:
https://www.sapien.com/blog/2012/05/16/ ... ive-forms/
I have used this in several projects successfully, however, in my most recent project, these background jobs will hang indefinitely and never process the contents of the "completescript" scriptblock. The contents of the "jobscript" script block will execute, but there appears to be an issue with the transition from the end of the "jobscript" scriptblock to the start of the "completeScript" block. Oddly, this issue started occurring around when the last powershell studio update was released. Any ideas?

DO NOT POST SUBSCRIPTIONS, KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM

User avatar
mxtrinidad
Site Admin
Posts: 351
Joined: Sun Mar 03, 2013 12:42 pm

Re: Background jobs not processing

Post by mxtrinidad » Wed May 09, 2018 7:53 am

If the issue is always happening. Can you provide an example? You could zip a solution and send it to us.
We would gladly take a look at it.

:)

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: Background jobs not processing

Post by davidc » Wed May 09, 2018 8:14 am

I responded to your original post here:

viewtopic.php?f=12&t=12586

The topic was moved to the PowerShell GUIs forum.
David
SAPIEN Technologies, Inc.

User avatar
whiggs2
Posts: 38
Joined: Sat Sep 23, 2017 11:59 pm

Re: Background jobs not processing

Post by whiggs2 » Wed May 09, 2018 9:16 am

This may be a stupid question, but should I remove the credential info? Also, can you provide me the link to upload files to sapien?

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: Background jobs not processing

Post by davidc » Wed May 09, 2018 9:55 am

The link is in the other thread. I'm going to lock this post so we don't have duplicate threads.
David
SAPIEN Technologies, Inc.