Page 1 of 1

Can't change DB Provider

Posted: Tue Aug 06, 2019 2:21 pm
by dakotazinn
To help you better we need some information from you.

*** Please fill in the fields below. If you leave fields empty or specify 'latest' rather than the actual version your answer will be delayed as we will be forced to ask you for this information. ***

Product: PowerShell Studio 2019 (64 Bit)
Build: v5.6.166
OS: Windows 10 Enterprise (64 Bit)
Build: v10.0.17763.0

*** Please add details and screenshots as needed below. ***

When creating an Access DB Connection in the Object Browser, I am unable to change the Provider
The Provider string "Provider=Microsoft.ACE.OLEDB.12.0" works on my machine, but the defaulting provider "Provider=Microsoft.Jet.OLEDB.4.0" 'Is not registered on this machine'
But when I change the provider string to ACE, as soon as I click 'OK', it defaults back to the JET provider

DO NOT POST SUBSCRIPTIONS, KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM

Re: Can't change DB Provider

Posted: Tue Aug 06, 2019 3:33 pm
by brittneyr
Thank you for reporting this issue. I was able to reproduce this and have filed an internal bug report. When I have more information to share, I'll post it here.

Re: Can't change DB Provider

Posted: Wed Aug 07, 2019 7:46 am
by brittneyr
For now, you should be able to connect with the OLEDB option, instead of the Access option, by entering your connection string:
SPS-DataConnections.png
SPS-DataConnections.png (17.27 KiB) Viewed 707 times

Re: Can't change DB Provider

Posted: Thu Aug 08, 2019 6:10 pm
by dakotazinn
Thank you, brittneyr