Page 3 of 4

Re: Cannot Build Any EXE Projects PSS 2019

Posted: Wed Aug 14, 2019 4:20 am
by phebenstreit
winver: version 1809 build 17763.615

Attached is a screen shot of the Tools Output. There is no OK button to click before or after the error. And there are no files in the bin/x64 or bin/86 created at any point in the process.

I will have zip uploaded in just a moment. It will be of a brand new Basic Forms Project; called "" with all requested files. The project has just 1 button, that performs a write host statement.

My machine is on a domain and subject to group policy. I can work on getting the software installed on a different system as well. I have checked the event viewer and AV logs, and have disabled AV and run into the same issues while it was disabled.

Thank you kindly for your assistance.

Could this be a .net issue? Older versions are also installed but i do believe 4.72 was recently applied as well.

Re: Cannot Build Any EXE Projects PSS 2019

Posted: Wed Aug 14, 2019 5:32 am
by Alexander Riedel
Thanks, we received your file.
Opened it and built it.
Build success.png
Build success.png (492.68 KiB) Viewed 1880 times
As you can see it works right away.
I doubt it is much dependent on the type or size of project.

No, .NET is not involved here. The packager is a C++ application and not dependent on .NET anything.
I am quite certain that somewhere something prevents writing the file, as the error indicates. Defect file system, permissions, some other blocking tool (white lister?), there are quite some possibilities.
I am out of ideas what to try at the moment other than using another machine, maybe your home machine, that is not part of your domain. If that works, which I suspect will happen, work backwards from there.

I'll think about what else we could investigate.

Re: Cannot Build Any EXE Projects PSS 2019

Posted: Wed Aug 14, 2019 7:10 am
by phebenstreit
I was able to just run the package process successfully. After installing a round of windows updates. I'm still not certain what is/was blocking the process, but if i find out specifically i can post.

It's also possible like you mentioned that a software blocking process; blocked the PSS 2019 build process.

Thank you for your time and effort on this.

Re: Cannot Build Any EXE Projects PSS 2019

Posted: Wed Aug 14, 2019 10:40 am
by phebenstreit
I located the issue. The x64 bit installer does not run the pre-requisite checker for PSS 2019. On the off chance there was an issue with the 64bit version on my machine, i downloaded and ran the installer for the x86 bit. The x86 installer ran the pre-requisite check and found that i did not have the C++ 2019 redistributables installed.

Once they were installed it works. So i would suggest updating your 64bit installer to run the pre-requisite check.

Re: Cannot Build Any EXE Projects PSS 2019

Posted: Fri Aug 16, 2019 9:09 am
by phebenstreit
Ok, backed to being stumped. The C++ installs didn't resolve the issue.
A few posts ago you asked if any files were created in the output folder; which they didn't appear to be. But if i continuously try to build the package, i can see that files are created.
I've also started to review a procmon log during the process; and the files are created and then removed. I haven't isolated any software installed on my computer that is locking or blocking the process. But still unclear as to why i cannot build the exe.

Tried multiple re-installs of both x86 and 64bit; and still no idea. Even reviewing the procmon log for the pss2019 process tree; i cannot identify what is happening; but i'm not a procmon guru by any stretch; just reviewing the basic output.

Other than success events i do have a few isolated ones. Project Name is "BasicTest3"
Class: file System Operation: CreateFileMapping Result: FILE LOCKED WITH ONLY READERS, for BasicTest3.exe.intermediate
And i have one entry for
Class: File System Operation: CreateFile Result: SHARING VIOLATION, for BasicTest3.exe.intermediate

There are also references to what appear to be two temporary files being created in the project output directory. RCXB58E.tmp and RCXB57D.tmp but everything else has a SUCCESS or strikes me as just noise.

Any ideas with this new info ?

Re: Cannot Build Any EXE Projects PSS 2019

Posted: Fri Aug 16, 2019 9:27 am
by brittneyr
Are you still receiving the "Error: Saving updated resources failed:110" error message?

Re: Cannot Build Any EXE Projects PSS 2019

Posted: Fri Aug 16, 2019 9:30 am
by phebenstreit
Yes, that is correct. The error and behavior is still the same. I thought I had found the issue but I spoke to soon.

Re: Cannot Build Any EXE Projects PSS 2019

Posted: Fri Aug 16, 2019 10:56 am
by brittneyr
Try disconnecting your computer from the network to isolate your machine and then see if you can build.

Also, its not a good idea to mix 32 bit and 64 bit installers because some shared components can be copied to the same location which can lead to unexpected errors.

Re: Cannot Build Any EXE Projects PSS 2019

Posted: Fri Aug 16, 2019 2:52 pm
by Olga_B
And here is some suggestions from stackoverflow ... failed-110

Re: Cannot Build Any EXE Projects PSS 2019

Posted: Tue Aug 20, 2019 5:26 am
by phebenstreit
I had seen those recommendations last week. About the only google reference i could find related to the 110 error.

I am not using windows Defender, so the specifics to disabling the A/V are different, but i have created exclusions in my A/V filter for all related Sapien program folders, and output locations. I have also manually run commands to ensure that the output directories are not read only "attrib -r +s "folder path" and "attrib -r -s "folder path" based on some online comments that some programs don't function where +s is added.

Neither produced any different results.

Also in terms of the x86 vs 64; my primary test is 64bit OS, 64bit Sapien install, v5 64bit output with command line. The other iterations have simply been to test if anything else would reliably work.

I think one of your original comments seems most likely; that the intermediate.exe is created then getting locked, then being deleted. But i cannot determine what process is locking that file. I'll try investigating with procmon a bit more.