Popup to install Microsoft Dot Net Framework 3.5

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST LICENSE NUMBERS, ACTIVATION KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
micky123
Posts: 4
Last visit: Tue Mar 10, 2020 8:37 am

Popup to install Microsoft Dot Net Framework 3.5

Post by micky123 »

To help you better we need some information from you.


Product, version and build: Sapien Powershell Studion 2020
64 bit version of product:
Operating system:
64 bit OS:
I have created an exe and every time I execute it, it ends with a dialog "The following feature couldn't be installed: Microsoft Dot Net Framework 3.5.
How can I get rid of this popup?

User avatar
mxtrinidad
Posts: 399
Last visit: Tue Jan 19, 2021 10:16 am

Re: Popup to install Microsoft Dot Net Framework 3.5

Post by mxtrinidad »

Can you please provide the requested information?
Product, version and build: Sapien Powershell Studion 2020 > what version?
64 bit version of product:
Operating system:
64 bit OS:

Also, which "Platform" you have selected to work in PowerShell Studio?

User avatar
micky123
Posts: 4
Last visit: Tue Mar 10, 2020 8:37 am

Re: Popup to install Microsoft Dot Net Framework 3.5

Post by micky123 »

Sapien Powershell Studio 2020 version 5.7.172.0
I am creating the exe on a Windows 10 machine and installing the created exe on another windows 10 machine

User avatar
mxtrinidad
Posts: 399
Last visit: Tue Jan 19, 2021 10:16 am

Re: Popup to install Microsoft Dot Net Framework 3.5

Post by mxtrinidad »

I'm assuming you're creating an executable from a script file. But, it still not clear what option you have selected.
Is it SAPIEN PowerShell v3(..)? Or, SAPIEN PowerShell v5(..).

The error is leading to believe that you're building the executable to use PowerShell v3.0. So, you need to install .NET Framework 3.5 in your machine to support the PowerShell v3 host.

We also suggest upgrading to PowerShell Studio v5.7.173, as we have fixed some bugs with the build process.

User avatar
micky123
Posts: 4
Last visit: Tue Mar 10, 2020 8:37 am

Re: Popup to install Microsoft Dot Net Framework 3.5

Post by micky123 »

mxtrinidad, Thanks for all your help. Changing the the host to V5 worked fine. I appreciate your time.

User avatar
mxtrinidad
Posts: 399
Last visit: Tue Jan 19, 2021 10:16 am

Re: Popup to install Microsoft Dot Net Framework 3.5

Post by mxtrinidad »

I'm glad to help!
:)