Debugging mode with F5 Not Prompting

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST LICENSE NUMBERS, ACTIVATION KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
Locked
User avatar
smokingjoe
Posts: 16
Joined: Wed Jul 22, 2015 4:20 am

Debugging mode with F5 Not Prompting

Post by smokingjoe »

Product: PowerShell Studio 2020 (64 Bit)
Build: v5.7.178
OS: Windows 10 Enterprise (64 Bit)
Build: v10.0.17134.0
*** Please add details and screenshots as needed below. ***

Normally when I run my scripts I would hit F5 and the parameters dialog would come up depending on the script; since the update I no longer see this behavior. If I am missing a setting or doing it wrong I would like to be corrected.

Right now I just make sure I have the defaults setup for testing and a breakpoint so I can step through the code.

David

User avatar
brittneyr
Site Admin
Posts: 503
Joined: Thu Jun 01, 2017 7:20 am

Re: Debugging mode with F5 Not Prompting

Post by brittneyr »

This behavior should be fixed in service release 5.7.179. If you don't wish to update then making your parameters mandatory will also work:
  1. [Parameter(Mandatory = $true)]
Brittney Ryn
SAPIEN Technologies, Inc.

User avatar
smokingjoe
Posts: 16
Joined: Wed Jul 22, 2015 4:20 am

Re: Debugging mode with F5 Not Prompting

Post by smokingjoe »

Just wanted to make sure I was not suffering from coffee deprivation.

Locked