TabControl issue

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST LICENSE NUMBERS, ACTIVATION KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
reinerwid
Posts: 1
Last visit: Wed May 05, 2021 11:07 am
Been upvoted: 1 time

TabControl issue

Post by reinerwid »

Product, version and build:
Product: PowerShell Studio 2020 (64 Bit)
Build: v5.7.182
OS: Windows 10 Pro (64 Bit)
Build: v10.0.19042.0
PowerShell version(s):
PSVersion 5.1.19041.610
PSEdition Desktop
PSVersion 7.1.0
PSEdition Core

Hello,
I am using a lot of tab controls in my apps and noticed since the last update that controls like buttons,comboboxes, radiobuttons and other controls can't be dragged in the tabpage to a different location they snap back to it's original location. A way to get around this is when I add a panel inside the tabpage like that I am able to move the controls to any location I want to, the strange thing is I can move the panel anywhere I want to.
Another way to move the controls is to select them and use the up/down/left/right keys.
The controls are not locked also snap to grid is set to false on the tabpage and the tabcontrol, anchor in the controls is set none.
In the options > designer > Layout mode the snap to line is selected
The Apps were build in a previous version of Powershell Studio, but even in a new created Form project I have the same behavior.

Any help is appreciated
Regards,
Reiner

User avatar
brittneyr
Site Admin
Posts: 820
Last visit: Tue Aug 03, 2021 7:42 am
Answers: 16
Been upvoted: 13 times

Re: TabControl issue

Post by brittneyr »

We will look into this and get back to you.
Brittney Ryn
SAPIEN Technologies, Inc.

User avatar
brittneyr
Site Admin
Posts: 820
Last visit: Tue Aug 03, 2021 7:42 am
Answers: 16
Been upvoted: 13 times

Re: TabControl issue

Post by brittneyr »

I have not been able to reproduce this behavior. The only time I would get the a button or radio control to go back to its original is when I tried to move to the controls partially off the tab control by the tabs, but this is expected as the cursor changed because this was not a location I could move the control:
TabControl.gif
TabControl.gif (1.39 MiB) Viewed 1373 times
Are there any specific properties you set on the controls? Can you please upload a sample form so I can determine if its something in your settings or the form controls themselves:
https://www.sapien.com/support/upload
Brittney Ryn
SAPIEN Technologies, Inc.

User avatar
brittneyr
Site Admin
Posts: 820
Last visit: Tue Aug 03, 2021 7:42 am
Answers: 16
Been upvoted: 13 times

Re: TabControl issue

Post by brittneyr »

I see the behavior you are talking about from the files you provided, but I've been unsuccessful at replicating the behavior.
How are you selecting and moving the control, with a keyboard or a mouse?
Brittney Ryn
SAPIEN Technologies, Inc.