ProgressBar not working?

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
dmorgan@kryptiq.com
Posts: 6
Joined: Fri Jun 08, 2012 5:31 am

ProgressBar not working?

Post by dmorgan@kryptiq.com » Tue Jun 12, 2012 7:43 am

Today I went to run a script I wrote a while back. This is a non-form script but it uses the Write-Progress commands to display a progress bar.

Running this from PowerGUI displays the progress bar just as I would expect (the forms progress bar - not the console version). If I run the same script from PowerShell Studio, the progress bar never gets displayed (although the script is running as expected).

To test this further, I created a blank script in PowerShell studio and put in a few Write-Progress lines with a few seconds of sleep between each command and I still never saw the progress bar. Ideas?

User avatar
Alexander Riedel
Posts: 7023
Joined: Tue May 29, 2007 4:43 pm

ProgressBar not working?

Post by Alexander Riedel » Tue Jun 12, 2012 10:42 am

Please send your test script (zipped) to support@sapien.comWe will look into it.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
dmorgan@kryptiq.com
Posts: 6
Joined: Fri Jun 08, 2012 5:31 am

ProgressBar not working?

Post by dmorgan@kryptiq.com » Wed Jun 13, 2012 1:36 am

Script sent.