WMI Problem

Ask your Windows PowerShell-related questions, including questions on cmdlet development!
Forum rules
Do not post any licensing information in this forum.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
Locked
User avatar
bluephx
Posts: 1
Joined: Fri Apr 25, 2008 8:56 am

WMI Problem

Post by bluephx » Mon Apr 28, 2008 6:31 am

I just purchased the PowerShell v2 book from Sapien Press, I'm trying to run through some examples but i am having trouble using any gwmi command that starts with win32.

I am running a 64-bit version Windows Vista, does this have anything to do with it? Is anyone else having problems with powershell v2 on a 64-bit machine. I have tried searching but havent had any luck. I've seen Don post about not using v2, but I would really prefer to keep it.

Thanks!

User avatar
donj
Posts: 416
Joined: Thu Nov 16, 2006 9:02 pm

WMI Problem

Post by donj » Sun May 04, 2008 11:51 pm

I'm great with people using v2 - just NOT in production, as it's not stable enough (in terms of design) to make a part of production processes.

Also keep in mind that v2's stability from OS to OS and platform to platform is variable. Right now the focus is mainly on Win2008 - once they reach "beta" stage they'll start worrying more specifically about the other versions of Windows. Not that they don't CARE right now, just that right now the bigger (not only) focus is on feature design. I've been doing all my testing in a Win2008 VM.

Locked