Unable To Use DataGridView

Ask questions about creating Graphical User Interfaces (GUI) in PowerShell and using WinForms controls.
Forum rules
Do not post any licensing information in this forum.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
Locked
MinnesotaJoe
Posts: 1
Joined: Thu Jul 02, 2020 6:04 am

Unable To Use DataGridView

Post by MinnesotaJoe »

No matter what I do, when I place a DataGridView in as part of the gui and try to run/preview/debug the thing the Output tab shows

Code: Select all

Cannot resolve dependency to assembly 'System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' because it has not been preloaded. When using the ReflectionOnly APIs, dependent assemblies must be pre-loaded or loaded on demand through the ReflectionOnlyAssemblyResolve event.
I would assume part of what PowerShell Studio does is help with this, but apparently not. How do I resolve this issue?
I verified I do have 'Enable PowerShell V2 assembly compatibility' enabled as well.

jvierra
Posts: 14476
Joined: Tue May 22, 2007 9:57 am
Contact:

Re: Unable To Use DataGridView

Post by jvierra »

PowerShell 2 has been removed by Microsoft. The option is not necessary.
Be sure you are selecting the current version of PowerShell.

Do not attempt to load forms assemblies as PSS will add the correct code when the PSF file is run.

A good way to isolate your issue is to start with the least amount of code and test. Failures with this usually indicate incorrect options or some installation issue.

For product specific issues you can post in the Customer Support forum to get help from Sapien.

User avatar
Lembasts
Posts: 301
Joined: Thu Mar 15, 2012 9:47 am

Re: Unable To Use DataGridView

Post by Lembasts »

Make sure you are running the latest version of PS Studio (179).

Locked