Some sub-folders not included

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST LICENSE NUMBERS, ACTIVATION KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
Locked
User avatar
WoofWolf
Posts: 4
Joined: Fri Mar 31, 2017 1:32 pm

Some sub-folders not included

Post by WoofWolf »

VersionRecall v1.6.152
Windows Server 2012R2 (64 bit of course), virtual machine
68GB RAM, copius HD space.

Using repository on secondary local drive (not SAN attached).

Some but not all folders are "copied" to the repository. I've tried several folders on C:, using repository on D: with the same result. Include subfolders is enabled. My filter includes all files (*.*) with no exclusions. Create versions and log activities is toggled ON. Limit versions is 0. No other options enabled.

First time using this product. Doesn't seem to be too fancy but appears I've overlooked something that reading the help doesn't address - user error for sure since I haven't seen this issue resolution anywhere.
It also is strange that one sub-sub-folder (225MB) takes 15+ minutes to scan and never gives a success. Some but not all of the content is in the repository.

User avatar
Olga_B
Site Admin
Posts: 147
Joined: Mon May 15, 2017 9:06 am

Re: Some sub-folders not included

Post by Olga_B »

Hello,
I was not able to reproduce the issue, and need a bit info from you:

- 'Some but not all folders are "copied" to the repository...' what kind of folders?
- how many files were submitted?
When you submitted files/folders first time, in Output panel should be message
' *** Operation completed*** xxx file(s) submitted, 0 file(s) locked'
- Did you create New repository using Wizard (on first run after install) or from File/New

User avatar
WoofWolf
Posts: 4
Joined: Fri Mar 31, 2017 1:32 pm

Re: Some sub-folders not included

Post by WoofWolf »

Folders are all local. Repository is local. Standard windows folders. Seems VersionRecall gets "stuck" on a folder and hangs. Happens for two different folder/repository configs. I can repeat the issue (every time). Repository name "A" source folder has 29,583 files, 606 folders, size 835MB. Repository "B" has 162 files, 16 folders, size 218MB. Used Repository/New to make each, not at first run after install. Have tried deleting and remaking again several times - same result. Perhaps open files (binaries) are the cause? File/folder ACLs are not an issue.

User avatar
brittneyr
Site Admin
Posts: 500
Joined: Thu Jun 01, 2017 7:20 am

Re: Some sub-folders not included

Post by brittneyr »

What types of files are not being included?

It might be getting stuck on a file. When it hangs, can you determine what file it was looking at from the output?
If you can determine that, can you please upload the file here to help us recreate this issue:
https://www.sapien.com/support/upload
Brittney Ryn
SAPIEN Technologies, Inc.

Locked