Problem with installation from PowerShell Studio. "Automatic" Cancel

Use this forum to ask questions about installation or issues encountered while installing our software.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.
User avatar
vobawf
Posts: 9
Joined: Wed Feb 14, 2018 9:35 am

Problem with installation from PowerShell Studio. "Automatic" Cancel

Post by vobawf » Thu Jun 21, 2018 7:16 am

To help you better we need some information from you.

*** Please fill in the fields below. If you leave fields empty or specify 'latest' rather than the actual version your answer will be delayed as we will be forced to ask you for this information. ***

Product, version and build: PowerShell Studio all versions
32 or 64 bit version of product: Both
Operating system: Windows 10 Enterprise - 1703 (Build 15063.1088)
32 or 64 bit OS: 64 bit

I have the same problem as already discussed here:
viewtopic.php?f=29&t=11864

After starting the installation with administrative rights the following appears:
cancel.png
cancel.png (22.21 KiB) Viewed 1480 times
If you press No it starts over and you return to the above box.

I tried several versions and all had the same problem. See this picture:
versions.png
versions.png (5.55 KiB) Viewed 1480 times
The same happens for example with the Sapien Update Tool 64bit.
With several different programs not from Sapien I had no problems.

I can't find any helpful infos in the eventlog.

I manually checked the required prerequisites and I think they are all installed.
Unpacking the installation file and starting "PowerShell Studio.exe" without proper installation works but some parts don't work perfect.

Our PCs don't have direct access to the internet because of the rigid settings by our datacenter.

Is there any other way to install PowerShellStudio?

Thanks for your support.

User avatar
Alexander Riedel
Posts: 6921
Joined: Tue May 29, 2007 4:43 pm

Re: Problem with installation from PowerShell Studio. "Automatic" Cancel

Post by Alexander Riedel » Thu Jun 21, 2018 7:45 am

It is probably trying to download and install the .NET runtime.
Which exact versions of that do you have installed?
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
vobawf
Posts: 9
Joined: Wed Feb 14, 2018 9:35 am

Re: Problem with installation from PowerShell Studio. "Automatic" Cancel

Post by vobawf » Thu Jun 21, 2018 9:40 am

This is an extract from the registry:
netframework.jpg
netframework.jpg (88.42 KiB) Viewed 1455 times
So it should be this one:
netframework2.jpg
netframework2.jpg (228.96 KiB) Viewed 1455 times

User avatar
Alexander Riedel
Posts: 6921
Joined: Tue May 29, 2007 4:43 pm

Re: Problem with installation from PowerShell Studio. "Automatic" Cancel

Post by Alexander Riedel » Thu Jun 21, 2018 10:40 pm

That doesn't show which frameworks are installed, it only shows one particular framework being installed.
Go to the installed apps control panel, that should list them.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
vobawf
Posts: 9
Joined: Wed Feb 14, 2018 9:35 am

Re: Problem with installation from PowerShell Studio. "Automatic" Cancel

Post by vobawf » Fri Jun 22, 2018 3:40 am

No, there aren't any listed.

User avatar
Alexander Riedel
Posts: 6921
Joined: Tue May 29, 2007 4:43 pm

Re: Problem with installation from PowerShell Studio. "Automatic" Cancel

Post by Alexander Riedel » Fri Jun 22, 2018 7:05 am

JVierra was nice enough to send me a script to extract the information:

Code: Select all

Get-ChildItem 'HKLM:\SOFTWARE\Microsoft\NET Framework Setup\NDP' -recurse |
    Get-ItemProperty -name Version,Release -EA 0 |
    Where { $_.PSChildName -match '^(?!S)\p{L}'} |
    Select PSChildName, Version, Release
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
vobawf
Posts: 9
Joined: Wed Feb 14, 2018 9:35 am

Re: Problem with installation from PowerShell Studio. "Automatic" Cancel

Post by vobawf » Sat Jun 23, 2018 12:05 am

OK, thank you.
Here is the info:

Code: Select all

PSChildName                      Version        Release
-----------                      -------        -------
v2.0.50727                       2.0.50727.4927
v3.0                             3.0.30729.4926
Windows Communication Foundation 3.0.4506.4926
Windows Presentation Foundation  3.0.6920.4902
v3.5                             3.5.30729.4926
Client                           4.7.02046      460798
Full                             4.7.02046      460798
Client                           4.0.0.0

User avatar
vobawf
Posts: 9
Joined: Wed Feb 14, 2018 9:35 am

Re: Problem with installation from PowerShell Studio. "Automatic" Cancel

Post by vobawf » Mon Jul 02, 2018 3:05 am

Hi Alexander,

any news?

User avatar
davidc
Posts: 5839
Joined: Thu Aug 18, 2011 4:56 am

Re: Problem with installation from PowerShell Studio. "Automatic" Cancel

Post by davidc » Fri Jul 06, 2018 8:35 am

Hello,

We haven't been able to reproduce the issue on our end.

Let’s make sure you have .NET 4.5.2 installed:

https://www.microsoft.com/net/download/ ... ime/net452


Then try running a silent install with logging to see what is happening:

Code: Select all

(installername).exe /exenoui /qn /L*v .\SPS_Install.log
You can attach the log to this post or upload it here:

https://www.sapien.com/support/upload
David
SAPIEN Technologies, Inc.

User avatar
vobawf
Posts: 9
Joined: Wed Feb 14, 2018 9:35 am

Re: Problem with installation from PowerShell Studio. "Automatic" Cancel

Post by vobawf » Mon Jul 09, 2018 6:13 am

Hi David,

There is no log file created with the command you posted.
I started it with admin rights.

But here is a screenshot after the installation finished.
The installation couldn't be executed because of the following reason:
NET Framework 4.5.2 or a newer update is already installed.
SS.png
SS.png (11.98 KiB) Viewed 1012 times
In my opinion since .NET Framework 4.7.0 is installed this error is normal.

Here is another screenshot of my Windows-Features.
Perhaps it helps.
ss2.png
ss2.png (16.16 KiB) Viewed 1012 times