Improper argument on startup and file save

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
gmichaud
Posts: 88
Joined: Mon Sep 12, 2011 1:58 am

Improper argument on startup and file save

Post by gmichaud » Tue Jun 11, 2019 9:12 am

Product: PrimalScript (64 Bit)
Build: v7.4.128
OS: Windows 10 Pro (64 Bit)
Build: v10.0.17763

I just recently started getting this error on startup when it is loading previously edited files. Not always, just now and then. Can't repro on demand.
Screenshot - 6_11_2019 , 10_59_59 AM.png
Screenshot - 6_11_2019 , 10_59_59 AM.png (6.79 KiB) Viewed 614 times
Only once - just now - I also got it on file save. PrimalScript keeps running, and I can't see anything obviously wrong so I just keep editing away.

FYI, We do use some long filenames. Over 50 characters. Also, our files are all UTF-16 LE.

I see other posts with that error, but I have not changed any templates recently and for me PS doesn't "CRASH". Just displays the error.
Thanks,
Gerry

User avatar
gmichaud
Posts: 88
Joined: Mon Sep 12, 2011 1:58 am

Re: Improper argument on startup and file save

Post by gmichaud » Tue Jun 11, 2019 9:26 am

Correction: I got the error on a file Save AS, and I just did it again. I tried a 3rd time, but no error.
Thanks,
Gerry

User avatar
Alexander Riedel
Posts: 7052
Joined: Tue May 29, 2007 4:43 pm

Re: Improper argument on startup and file save

Post by Alexander Riedel » Tue Jun 11, 2019 9:29 am

on a SaveAs....
I will have a look.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
Alexander Riedel
Posts: 7052
Joined: Tue May 29, 2007 4:43 pm

Re: Improper argument on startup and file save

Post by Alexander Riedel » Tue Jun 11, 2019 9:36 am

Can you give us an example of what the name of the file is (full path) and what you are saving it as (also full path)?
Maybe we can replicate it.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
gmichaud
Posts: 88
Joined: Mon Sep 12, 2011 1:58 am

Re: Improper argument on startup and file save

Post by gmichaud » Tue Jun 11, 2019 1:02 pm

Here is the full path to the file I saved AS...

"C:\Users\Gerry\Script Library\VB Installers\1546131 - ## Apps Packaging\Camtasia 8 Refresh\TechSmith Camtasia 8\UTC-ENG-TechSmith-CamtasiaStudio-v8.6.0-ALL-r1.0.vbs"

Note that I've been editing files with similar paths for years. The only thing new here is the use of ## in the folder name. And the error happens only occasionally. I'd say I've seen it a total of 5 times including twice today.
Thanks,
Gerry

User avatar
Alexander Riedel
Posts: 7052
Joined: Tue May 29, 2007 4:43 pm

Re: Improper argument on startup and file save

Post by Alexander Riedel » Tue Jun 11, 2019 10:38 pm

I'll see what I can find out today
Alexander Riedel
SAPIEN Technologies, Inc.